[SNES] lobo bad header

Post all database contributions here.
Post Reply
User avatar
romcenter
Posts: 42
Joined: 27 Jun 2008 12:00

[SNES] lobo bad header

Post by romcenter » 21 Apr 2018 07:52

Hi

During some debug with romcenter, I checked the snes lobo rom (crc 890DC31C) with ucon tool and it seems the header is bad.

Code: Select all

Multi Game Doctor 2/MGD2/Multi Game Hunter/MGH

00007fb0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00007fc0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................
00007fd0  00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  ................

Super Nintendo Entertainment System/SNES/Super Famicom

Demo or Beta ROM?
Japan
3145728 Bytes (24.0000 Mb)

Padded: No
Interleaved/Swapped: Yes
Backup unit/emulator header: No
HiROM: No
Internal size: 0 Mb
ROM type: (0) ROM
ROM speed: 200 ns (SlowROM)
SRAM: No
Version: 1.0
Checksum: Bad, 0x940d (calculated) != 0x0000 (internal)
Inverse checksum: Bad, 0x6bf2 (calculated) != 0x0000 (internal)
Search checksum (CRC32): 0x0d9d9367
Data checksum (CRC32): 0x890dc31c
I found a 'fixed header' version (crc 9AC64A34) which is reported good. Don't know why no-intro still references the bad one ?

Code: Select all

Multi Game Doctor 2/MGD2/Multi Game Hunter/MGH

00007fb0  ff ff ff ff  ff ff ff ff  ff ff ff ff  ff ff ff ff  ................
00007fc0  4c 4f 42 4f  20 20 20 20  20 20 20 20  20 20 20 20  LOBO
00007fd0  20 20 20 20  20 ff ff 0c  00 01 33 00  ba 96 45 69       .....3...Ei

Super Nintendo Entertainment System/SNES/Super Famicom
LOBO
Unknown
U.S.A.
3145728 Bytes (24.0000 Mb)

Padded: No
Interleaved/Swapped: No
Backup unit/emulator header: No
HiROM: No
Internal size: 32 Mb
ROM type: (ff) ROM + SRAM + Unknown
ROM speed: 120 ns (FastROM)
SRAM: No
Version: 1.0
Checksum: OK, 0x6945 (calculated) == 0x6945 (internal)
Inverse checksum: OK, 0x96ba (calculated) == 0x96ba (internal)
Checksum (CRC32): 0x9ac64a34
--
Eric
www.romcenter.com

badinsults
Posts: 252
Joined: 05 Jun 2008 01:34

Re: [SNES] lobo bad header

Post by badinsults » 21 Apr 2018 10:08

I imagine any dump of Lobo is going to be suspicious, since it originated from a bootleg cart. Who knows if either one is correct?

KingMike
Posts: 360
Joined: 22 Sep 2012 16:36

Re: [SNES] lobo bad header

Post by KingMike » 21 Apr 2018 17:23

Prototypes didn't usually have correct headers since they weren't needed for the game to run.
I believe no-intro would rather have original data than "fixed" data.

User avatar
romcenter
Posts: 42
Joined: 27 Jun 2008 12:00

Re: [SNES] lobo bad header

Post by romcenter » 22 Apr 2018 13:36

Yes, seems correct. Thanks.

Post Reply