HTTPS Support for *all* of No-Intro?

Post bug reports and suggestions for the website, forums and DOM here.
Post Reply
InternalLoss
Posts: 24
Joined: 23 May 2018 00:03

HTTPS Support for *all* of No-Intro?

Post by InternalLoss » 03 Mar 2019 23:35

A lot of browsers now warn users about the fact that they are entering text of any kind into HTTP sites, especially login fields. While DAT-O-Matic has HTTPS support over Let's Encrypt (albeit not in any way that most modern browsers know of), the forums and main site do not support HTTPS at all. Surely this should be changed?

I understand that some older apps use DATOMatic over HTTP, so I'm not saying we must 302 all HTTP requests to HTTPS or anything like that. However, support could be added if it's obvious that a browser can support it (Forums should probably have enforced HTTPS due to their login sections, but I digress), because a lot of browsers now warn that an entire site is not secure, and it'd be nice to see us upgrade a bit ;p

User avatar
xuom2
High Council
Posts: 803
Joined: 22 May 2008 18:45

Re: HTTPS Support for *all* of No-Intro?

Post by xuom2 » 04 Mar 2019 22:09

testing with DOM: is it forwarding from HTTP to HTTPS now?

InternalLoss
Posts: 24
Joined: 23 May 2018 00:03

Re: HTTPS Support for *all* of No-Intro?

Post by InternalLoss » 05 Mar 2019 01:14

I can confirm the redirect works! I also tested a http link to make sure they wouldn't break on redirect, and they do not, so it works fine :D

It'd be nice to test forums+main site now, if possible <3

Pr3tty F1y
Posts: 17
Joined: 19 Jul 2014 21:24

Re: HTTPS Support for *all* of No-Intro?

Post by Pr3tty F1y » 16 Apr 2019 00:40

Did this break CLRMAMEPro access to datomatic.nointro.org/profile.xml? I'm not able to access the xml (through CMPro or directly) at the moment.

Post Reply